Subject: Re: Xircom PCMCIA NIC problem with new install of
FreeBSD 4.5-Rel



On Tuesday 19 March 2002 16:22, you wrote:
> > From: Michael W.Holdeman <ptfd9100@xxxxxxxxxxxxx>
> > Date: Tue, 19 Mar 2002 15:31:25 -0500
> > Sender: owner-freebsd-mobile@xxxxxxxxxxx
> >
> >
> > I went to the archives, and got some info, as well as help from here.
> > Mine (REM56+) is working now but I still have to do ifconfig and set the
> > address, and defailt route every time I boot up. The pccard_flags+"-z" is
> > supposed to keep the system from finishing rc.conf untill the nic is done
> > but I haven't got it right yet.
>
> Add pccardd_flags="-z" to /etc/rc.conf. Note the "dd"!

OOPS, fat fingers!! Typo, I just checked.


> > Here is what I had to do to get mine to at least configure.
> >
> > Add to /etc/sysctl.conf
> >
> >
> >
> > # /etc/sysctl.conf
> > machdep.pccard.mem_start=oxdoooo
> >
> > ___________________________________________________________
> > I added to /etc/rc.conf
> >
> >
> > # /etc/rc.conf
> > linux_enable="Yes"
> > pccard_enable="YES"
> > pccard_mem="0xd0000"
> > pccard_ifconfig_xe0="inet 192.168.14.8 netmask 255.255.255.0"
>
> Should be either pccard_ifconfig OR ifconfig_xe0. pccard_ifconfig_xe0
> will do nothing. pccard_ifconfig do the same ifconfig for ANY pccard
> NIC while ifconfig_xe0 will apply ONLY to the first interface that
> uses the xe driver.

Thanks,
I'll make this change post haste!


Mike
r>

To Unsubscribe: send mail to majordomo@xxxxxxxxxxx
with "unsubscribe freebsd-mobile" in the body of the message





Privacy