Subject: AW: [Postscript] German umlauts are not shown for
Postscript output of Trunk



Hi Jeremias,

I enabled the suggested PS renderer option and checked both FOP trunk
versions with and without your latest changes. The umlaut problem is fixed
only halfway. My document uses two fonts, 'Times New Roman' (resolved as
'any' font) and 'Arial' (refered to using metrics declarations in
fop.xconf). For 'Times New Roman' turning on the optimization option has
fixed the problem in both versions. For 'Arial' the problem still remains in
Trunk.
I'll recover back to FOP 0.95 for now.

Regards, Ingo

> -----Ursprüngliche Nachricht-----
> Von: Jeremias Maerki [mailto:dev@xxxxxxxxxxxxxxxxxx]
> Gesendet: Montag, 9. Februar 2009 10:25
> An: fop-users@xxxxxxxxxxxxxxxxxxxxxx
> Betreff: Re: [Postscript] German umlauts are not shown for
> Postscript output of Trunk
>
> Fixed in FOP Trunk: http://svn.apache.org/viewvc?rev=742346&view=rev
> Should now also work without resource optimization, though
> turning on resource optimization is recommended if you want
> smaller PostScript files containing only what you really need.
>
> On 09.02.2009 09:44:02 Jeremias Maerki wrote:
> > I think I know now what the problem is. You're using PS
> output with no
> > "resource optimization" [1] (the default). In that mode,
> the fonts are
> > set up before we know what characters are used. I seem to have
> > forgotten to test the PS output in that mode after my
> changes to make
> > all available glyphs in a Type 1 font usable in PostScript. The
> > short-term work-around is to enable "resource optimization":
> > <optimize-resources>true</optimize-resources> in the configuration.
> >
> > I'll see to it that this gets fixed.
> >
> > [1]
> > http://xmlgraphics.apache.org/fop/trunk/output.html#ps-configuration
> >
> > On 06.02.2009 17:01:39 Ingo Maas wrote:
> > > Hi,
> > >
> > > Recently, I upgraded to current Trunk. I noticed that
> German umlauts
> > > are not shown for Postscript output anymore. Using release 0.95,
> > > German umlauts look fine.
> > > I have made a diff of both output documents, and there are some
> > > subtle differences, see attached files. Both documents do contain
> > > the octal entities for the umlauts.
> > > I'm using font metrics definitions for Type 1 fonts for
> Postscript
> > > renderer in configuration file 'fop.xconf'.
> > >
> > > Can someone have a look at it to confirm that something
> is broken in
> > > Postscript renderer output in Trunk, please?
> > >
> > > Regards, Ingo
>
>
> Jeremias Maerki
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: fop-users-unsubscribe@xxxxxxxxxxxxxxxxxxxxxx
> For additional commands, e-mail: fop-users-help@xxxxxxxxxxxxxxxxxxxxxx
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: fop-users-unsubscribe@xxxxxxxxxxxxxxxxxxxxxx
For additional commands, e-mail: fop-users-help@xxxxxxxxxxxxxxxxxxxxxx



Privacy