MySQL-Cocoa database access



Hi Friends,

I am communicating with the MySQL database through the SMySQL framework.
I can open the database connection successfully.
I can select the database too.

When I send a query to read the max count in the primary key i get the value
in return for the first time.
Then I insert the new record in the database with the next count.
I perform the above 2 tasks in the loop.

In the second iteration itself my select query fails.

Can anyone suggest why does this happen?

I tried reconnecting the database in the loop. Also tried to add sleep for 1
second, but it's not worth for updating thousands of records.

Please suggest some solution.
Is anyone know the other framework which i can use for mysql-cocoa
connection?

Best Regards,
Sparta...
_______________________________________________

Cocoa-dev mailing list (Cocoa-dev@xxxxxxxxxxxxxxx)

Please do not post admin requests or moderator comments to the list.
Contact the moderators at cocoa-dev-admins(at)lists.apple.com

Help/Unsubscribe/Update your Subscription:
http://lists.apple.com/mailman/options/cocoa-dev/maillists%40codeha.us

This email sent to maillists@xxxxxxxxx

...



Privacy