Subject: [ccnet-user] Re: Farm report and Project report
disagree



Hi


can you have a look at the time stamps
in the lower left corner, just beneath the grid,
is a timestamp when the page was rendered.

is there a great difference between these 2 time stamps?


also is it really the status that says OK in the farm report,
and failed in the build report?


or do you see some errors in the build report,
but the status is ok --> green

so a screenshot could be handy


with kind regards
Ruben Willems



On Tue, Sep 29, 2009 at 9:38 PM, htoomik <helen@xxxxxxxxxx> wrote:


Yes, exactly as you describe - the two reports tell me different
things.
I use Firefox.

Perhaps next time this happens I could record the occurrence. A
screenshot would prove my point but not give much information about
the underlying cause... Which files would be useful to take snapshots
of, to help figure this out?

On Sep 29, 8:30 pm, Ruben Willems <ruben.will...@xxxxxxxxx> wrote:
> Hi
>
> You mean that the farm report says build ok,
> the individual build report is not ok.
> And when navigating back to the famr report, that build shows still as ok?
>
> if so, can you do a force refresh on the farm report?
> are yo using IE as a browser?
>
> just trying to find out what the problem may be,
> I've never seen this behaviour myself :-(
>
> with kind regards
> Ruben Willems
>
>
>
> On Tue, Sep 29, 2009 at 6:08 PM, htoomik <he...@xxxxxxxxxx> wrote:
>
> > Thanks for looking at this.
>
> > Actually I'm quite OK with the build failing in these cases. What's
> > bothering me is that the build looks OK according to the Farm report -
> > only when I go to the project report for that particular project do I
> > find out that there were errors and the build didn't succeed. I.e. the
> > build fails silently.
>
> > On Sep 29, 3:34 pm, Ruben Willems <ruben.will...@xxxxxxxxx> wrote:
> > > Hi
>
> > > take a look at the following properties in your ccnet.config file
> > > maxSourceControlRetries
> > > stopProjectOnReachingMaxSourceControlRetries
> > > sourceControlErrorHandling
>
> > >http://confluence.public.thoughtworks.org/display/CCNET/Project+Confi...
>
> > > these control what to do with source control errors
>
> > > with kind regards
> > > Ruben Willems
>
> > > On Tue, Sep 29, 2009 at 3:26 PM, htoomik <he...@xxxxxxxxxx> wrote:
>
> > > > Version 1.4.4.83, according to the dashboard.
>
> > > > On 29 Sep, 14:38, Ruben Willems <ruben.will...@xxxxxxxxx> wrote:
> > > > > Hi
>
> > > > > what version of ccnet are you using?
>
> > > > > with kind regards
> > > > > Ruben Willems
>
> > > > > On Tue, Sep 29, 2009 at 2:15 PM, htoomik <he...@xxxxxxxxxx> wrote:
>
> > > > > > Sometimes, when there are build errors (due to SVN conflicts, in
> > our
> > > > > > case) the report for that particular project reports it as FAILED,
> > > > > > while the dashboard (and CCTray) still lists that build as
> > successful.
>
> > > > > > This sort of unreliability takes away most of the benefits of
> > having a
> > > > > > CI server.
>
> > > > > > How can I fix the dashboard so that build errors are properly
> > reported?



Privacy