Subject: bug#2790: emacs 22.1.1 cannot open 5GB file on
64GB 64-bit GNU/Linux box

On Thu, Mar 26, 2009 at 11:59 PM, Richard M Stallman <rms@xxxxxxx> wrote:
> Please try the pretest of Emacs 23 and see if it works.
> See
> And please don't call it a "Linux box".  The system running in it
> is more GNU than Linux, so please call it a GNU/Linux box.
> (See

Okay, tried it (emacs-23.0.91), but no luck. Looks very nice, but
finding that large file produced the same error. The value of
'most-positive-fixnum' prints correctly, though (which is different).

The smallest file that produces the error has 536870912 bytes, exactly
512MB. (This is via binary search, so assumes that there is just one
transition from "will" to "won't" as filesize increases.)

On an unrelated note, I did see the following message in the 'make
install' output, for what it's worth:

gzip: ./quail/hangul3.el: No such file or directory

It didn't stop the install, though.


P.S. Re GNU/Linux, yes, preaching to the choir. Thanks for the reminder.