Subject: [Bacula-users] Network buffer size 512 not
multiple of tape block size - ON DISK!!!




Hi,

I am very frustrating with this.

I have a Celerra Nas that exports NFS Filesystem.

On Linux server (director and storage daemon) I mount the Filesystem in
the next manner:

10.1.232.2:/fs_Bacula /Vols_Bacula nfs rw,bg,hard,intr,rsize=32768,wsize=32768
0 0

On Storage Daemon i have ONLY the next definition:


Device {
Name = FileStorage
Media Type = File
Archive Device = /Vols_Bacula
LabelMedia = yes; # lets Bacula label unlabeled media
Random Access = Yes;
AutomaticMount = yes; # when device opened, read it
RemovableMedia = no;
AlwaysOpen = no;
}


On Client Daemon i have the next definition:

Name = a0171f01-fd
FDport = 9102 # where we listen for the director
WorkingDirectory = "C:\\Program Files\\Bacula\\working"
Pid Directory = "C:\\Program Files\\Bacula\\working"
Maximum Concurrent Jobs = 10
Maximum Network Buffer Size = 512
Heartbeat Interval = 5
}

As first case:
When i launch the job always I have the next error:

"Network buffer size 512 not multiple of tape block size."

But not awlways at same point. Sometimes at 20 mg copied, some times at 8
Gb copied.

I have tried to change "Maximum Network Buffer Size" to others values
multiple of 32768 but unsuccessfully.


As second case:
I have tried setup "Maximum Network Buffer Size" to 32768 but i obtain the
next error:

"Write error sending 32768 bytes to Storage daemon:A01CD901:9103:
ERR=Input/output error"
"Network error reading from FD. ERR=No data available "

Only at first case, windows file daemon crash.

Please, i am very desperate with this.

Thanks a lot.

Environment:
Ubuntu 10.04.2 LTS (Lucid Lynx)
Bac...

ula (dir,sd and fd) 5.0.3
fd -> Windows 2000 Server 5.0.2195 SP 4 Build 2195






------------------------------------------------------------------------------
WhatsUp Gold - Download Free Network Management Software
The most intuitive, comprehensive, and cost-effective network
management toolset available today. Delivers lowest initial
acquisition cost and overall TCO of any competing solution.
http://p.sf.net/sfu/whatsupgold-sd
_______________________________________________
Bacula-users mailing list
Bacula-users@xxxxxxxxxxxxxxxxxxxxx
https://lists.sourceforge.net/lists/listinfo/bacula-users



Privacy