osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [users@httpd] 403 error upon upgrade


Well, I have now set SuSE's YaST to reconfigure apache2 using the same vhosts.conf file while ensuring that php5 is running. Now apache won't start. I have moved from a 403 error to a site can't be reached error. I get the following output from systemctl status apache2.service:

apache2.service - The Apache Webserver
   Loaded: loaded (/usr/lib/systemd/system/apache2.service; enabled)
   Active: failed (Result: exit-code) since Wed 2018-10-03 14:44:01 PDT; 6min ago
  Process: 4006 ExecStop=/usr/sbin/start_apache2 -DSYSTEMD -DFOREGROUND -k graceful-stop (code=exited, status=0/SUCCESS)
  Process: 3998 ExecStart=/usr/sbin/start_apache2 -DSYSTEMD -DFOREGROUND -k start (code=exited, status=1/FAILURE)
 Main PID: 3998 (code=exited, status=1/FAILURE)

Oct 03 14:44:01 donner start_apache2[3998]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:443
Oct 03 14:44:01 donner start_apache2[3998]: (98)Address already in use: AH00072: make_sock: could not bind to address 0.0.0.0:80
Oct 03 14:44:01 donner start_apache2[3998]: no listening sockets available, shutting down
Oct 03 14:44:01 donner start_apache2[3998]: AH00015: Unable to open logs
Oct 03 14:44:01 donner systemd[1]: apache2.service: main process exited, code=exited, status=1/FAILURE
Oct 03 14:44:01 donner start_apache2[4006]: httpd (no pid file) not running
Oct 03 14:44:01 donner systemd[1]: Failed to start The Apache Webserver.
Oct 03 14:44:01 donner systemd[1]: Unit apache2.service entered failed state.

Any hints?