OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [users@httpd] PHP-7.2.5 with Apache-2.4.25


You're referring to php *extensions*, to be clear. A module with httpd would be a DSO, such as mod_php. Further, httpd modules are not unloaded as such; they remain loaded for the entire life of every child process.

Anyway, if your php extension can't be loaded for whatever reason, it would be useful to get a backtrace and/or a useful error.

On Fri, Jun 29, 2018 at 2:16 AM Hemant Chaudhary <hemantdude.chaudhary@xxxxxxxxx> wrote:
Hi Frank,

When we start server which has mod_php then during it first dry run, it loads the module and deload the module. After successful completion of first dry run, it reads the configuration file second time and starts the apache server.
During first dry run, dlopen() function loads the php module properly but while deloading it using dlclose() it is throwing error. This means that mod_php is not able to unload properly.

Hemant 

On Thu, Jun 28, 2018 at 5:45 PM, Frank Gingras <thumbs@xxxxxxxxxx> wrote:
What does "mod_php is not able to unload properly" mean in this case?

Secondly, any reason why you're not using php-fpm with a threaded httpd mpm instead?

On Wed, Jun 27, 2018 at 10:21 AM David Copeland <david.copeland@xxxxxxxxxx> wrote:
Okay, sorry, probably can't help then. I'm running Opensuse 42.3, Apache 2.4.33 (prefork) and mod_php 7.2.7.

The one thing I forgot about when I originally switched from php 5 to 7 was the APACHE_MODULES variable in the file /etc/sysconfig/apache2, changing php5 to php7. But each os/distro likes to tweak the config files so not sure if this applies to you.

Dave.

On 27/06/18 10:06 AM, Hemant Chaudhary wrote:
Its NonStop (tandem)

On Jun 27, 2018 7:35 PM, "David Copeland" <david.copeland@xxxxxxxxxx> wrote:
What platform/distribution are you running?

On 27/06/18 06:09 AM, Hemant Chaudhary wrote:
> Hi,
>
> I was using mod_php of php-5.5.37 with apache-2.4.25 and it was
> working fine. I upgraded the php to php-7.2.5. But after upgrade,
> mod_php is not able to unload properly. 
>
> Does anybody also face the same issue.
>
> Thanks
> Hemant


--
David Copeland
JSI Data Systems Limited
613-727-9353
www.jsidata.ca


---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx



-- 
David Copeland
JSI Data Systems Limited
613-727-9353
www.jsidata.ca