OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[users@httpd] apache2 can not find the file


Hi,
About my problem with apache which I described in another thread, I will know explain what I did from scratch.

See the system specs below


root@webshub:/var/www/html# ls
backedupindex.html  install_info.txt  ow_install      ow_smarty          ow_userfiles    shub
captcha.php         ow_core           ow_libraries    ow_static          ow_utilities    UPDATE.txt
CHANGELOG.txt       ow_cron           ow_log          ow_system_plugins  ow_version.xml
e500.php            ow_iis            ow_pluginfiles  ow_themes          ReadMe.pdf
index.php           ow_includes       ow_plugins      ow_updates         robots.txt
root@webshub:/var/www/html# cat /etc/apache2/sites-available/000-default.conf
<VirtualHost *:80>
    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html
        <Directory /var/www/html/>
             Options FollowSymLinks
             AllowOverride All
             Order allow,deny
             allow from all
        </Directory>
    LogLevel debug
    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined
</VirtualHost>
root@webshub:/var/www/html#

root@webshub:/var/www/html# service apache2 restart




Now from another machine (my laptop in home), I ran the following command. Please note that w.x.y.z is the same as what I see in the ifconfig on the 'webshub' machine


mahmood@orca:~# wget http://w.x.y.z -O file.txt
--2018-06-03 22:30:02--  http://w.x.y.z/
Connecting to w.x.y.z:80... connected.
HTTP request sent, awaiting response... 301 Moved Permanently
Location: http://w.x.y.z/install [following]
--2018-06-03 22:30:02--  http://w.x.y.z/install
Reusing existing connection to w.x.y.z:80.
HTTP request sent, awaiting response... 404 Not Found
2018-06-03 22:30:02 ERROR 404: Not Found.



At the same time that I ran wget on my laptop, in 'webshub' machine, I ran "tail -f /var/log/apache2/error.log" and see this output


[Sun Jun 03 22:33:23.671003 2018] [authz_core:debug] [pid 30012] mod_authz_core.c(809): [client 37.31.42.129:47438] AH01626: authorization result of Require all granted: granted
[Sun Jun 03 22:33:23.671197 2018] [authz_core:debug] [pid 30012] mod_authz_core.c(809): [client 37.31.42.129:47438] AH01626: authorization result of <RequireAny>: granted
[Sun Jun 03 22:33:23.671430 2018] [authz_core:debug] [pid 30012] mod_authz_core.c(809): [client 37.31.42.129:47438] AH01626: authorization result of Require all granted: granted
[Sun Jun 03 22:33:23.671457 2018] [authz_core:debug] [pid 30012] mod_authz_core.c(809): [client 37.31.42.129:47438] AH01626: authorization result of <RequireAny>: granted
[Sun Jun 03 22:33:23.710282 2018] [authz_core:debug] [pid 30012] mod_authz_core.c(809): [client 37.31.42.129:47438] AH01626: authorization result of Require all granted: granted
[Sun Jun 03 22:33:23.710326 2018] [authz_core:debug] [pid 30012] mod_authz_core.c(809): [client 37.31.42.129:47438] AH01626: authorization result of <RequireAny>: granted
[Sun Jun 03 22:33:23.710380 2018] [core:info] [pid 30012] [client 37.31.42.129:47438] AH00128: File does not exist: /var/www/html/install



What does that mean? Does that mean there is no 'install' file in /var/www/html?



Regards,
Mahmood