OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [users@httpd] SSI/website rendering errors



> Date: Thursday, December 14, 2017 23:07:37 +0000
> From: jm07052@xxxxxxxxx
>
> Although my website was functioning properly on Monday, 12/11/17, it
> exhibited several errors the following day (12/12/17). No changes
> were made to any of the files after 12/6 (the last being an SSI
> text file on 12/6). Several of the base html files are nearly nine
> years old (I modify the SSI include files as needed, and rarely
> touch the others).
> 
> The site is coded in XHTML 1.0 Strict and until 12/12 the code has
> been fully compliant (per W3C HTML and CSS validators). I suspect
> it may have something to do with SSI, which is used extensively on
> the site, but I have seen only one possibly-related post concerning
> a recent Apache release (Critical Changes In Apache 2.4 -
> https://documentation.cpanel.net/display/EA/Critical+Changes+In+Apa
> che+2.4#CriticalChangesInApache2.4-Server-SideInclude(SSI)Expressio
> nParser).
> 
> The server OS is LiteSpeed (Apache Version 2.4.29). The hosting
> company stated that no patches were applied to the system after the
> 11th, but I note that LiteSpeed released LSWS v. 5.2.3 on 12/11/17,
> the last day on which the website was working correctly.  (This
> query is also posted on a LiteSpeed forum.)
> 
> All suggestions are welcome.

And the errors you are seeing - on the pages with rendering problems
and in the logs? Without even that basic detail all anyone can do is
guess.






---------------------------------------------------------------------
To unsubscribe, e-mail: users-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: users-help@xxxxxxxxxxxxxxxx