OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [NOTICE] Intent to T&R 2.4.37 - about 12:00 GMT tomorrow



> Am 18.10.2018 um 14:12 schrieb Rainer Jung <rainer.jung@xxxxxxxxxxx>:
> 
> - t/modules/http2.t fails when the server is build using OpenSSL 0.9.8zh with the "Bad plan.  You planned 52 tests..." message indicating, that h2 using TLS does not work. It happens on all platforms, but not if the client also uses OpenSSL 0.9.8zh.
> 
> I don't know whether that is expected for old OpenSSL, so can not judge on criticality.

AFAICT, correct me if I am wrong, OpenSSL 0.9.8 does not support TLSv1.2 and is therefore unusable with h2. The test suite seems to be unprepared for this scenario. I will remove it after the next release. It is not worth fixing in its current form.

-Stefan