OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: NOTICE: Intent to T&R 2.4.35 in the next few hours



Are there  examples what (maybe) does not work with OpenSSL 1.1.1 ?

Build 2.4.35 with OpenSSL 1.1.1, no issues seen/reported.

More then A week ago I ask already the community to test 2.4.34 with OpenSSL 1.1.1 
also no issue reported.

Plan to ship 2.4.35 with OpenSSL1.1.1

With our announcement I put the note:  

....Apache 2.4.35 does not support yet TLSv1.3, expected in 2.4.36 release......

Note:
openssl.org says that the new 1.1.1 is binary and API/ABI compatible with OpenSSL 1.1.0.
I can confirm that sofar and also windows PHP-guys.




 
On Wednesday 19/09/2018 at 12:54, Joe Orton wrote:
On Tue, Sep 18, 2018 at 11:19:10AM -0500, William A Rowe Jr wrote:
On Tue, Sep 18, 2018 at 2:43 AM Joe Orton <jorton@xxxxxxxxxx> wrote:
You'll likely see issues testing against OpenSSL 1.1.1 until the TLSv1.3
merge is integrated for 2.4.x, yeah, I wouldn't worry about that.

But I think this is worth highlighting in our Announcement, that we would
strongly caution users to build 2.4.35 against OpenSSL 1.1.0. (And we
could tease the forthcoming 2.4 release as building against 1.1.1/TLS 1.3.)

Good idea. How about this, to insert after the "This release requires
the Apache Portable Runtime (APR)," paragraph?

"""
This release is compatible with OpenSSL versions from 0.9.8a to
1.1.0 only, and does not support TLSv1.3. Future releases of httpd 2.4
are expected to add compatibility with OpenSSL 1.1.1 and enable support
for TLSv1.3.
"""

Regards, Joe