OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 62638] New: WebDAV gives system error 67 or 53 on Windows 10


https://bz.apache.org/bugzilla/show_bug.cgi?id=62638

            Bug ID: 62638
           Summary: WebDAV gives system error 67 or 53 on Windows 10
           Product: Apache httpd-2
           Version: 2.5-HEAD
          Hardware: PC
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_dav
          Assignee: bugs@xxxxxxxxxxxxxxxx
          Reporter: alex1452@xxxxxxx
  Target Milestone: ---

I am on:
Server version: Apache/2.4.29 (Ubuntu)
Server built:   2018-06-07T21:10:10

I have set WebDAV with apache 2.4 using the following lines:
Alias /mydav /srv/mydav
<Location /mydav>
        Dav On
        AuthType Basic
        AuthName "WebDAV"
        AuthUserFile /etc/apache2/.htpasswd

        <LimitExcept GET OPTIONS>
                Require valid-user
        </LimitExcept>
</Location> 

I have activated basic authentication without SSL:
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\WebClient\Parameters]
"BasicAuthLevel"=dword:00000002

However, Windows 10 gives the following error messages:
net use * http(s)://server.tld/mydav /user:user - System Error 67
net use * \\server.tld@SSL\mydav /user:user - System Error 53

Apache does not show anything in error log. Access log contains the following
entry:
192.168.99.115 - - [20/Aug/2018:08:12:50 +0000] "OPTIONS / HTTP/1.1" 200 218
"-" "Microsoft-WebDAV-MiniRedir/10.0.17134"
192.168.99.115 - - [20/Aug/2018:08:12:50 +0000] "PROPFIND /mydav HTTP/1.1" 301
580 "-" "Microsoft-WebDAV-MiniRedir/10.0.17134"
192.168.99.115 - - [20/Aug/2018:08:12:50 +0000] "PROPFIND /mydav/ HTTP/1.1" 403
520 "-" "Microsoft-WebDAV-MiniRedir/10.0.17134"

The issue seems to be a different way that the windows mini-redirector
communicates with httpd. Other clients like Cadaver work with this setup.
However, with the (still) high relevance of Windows, it seems to be importan t
to correctly work with Windows 10 WebDav redirector.

Side note: I can connect with the same windows instance to other WebDav sites
(eg. gmx.net) without any problems. So the issue does not seem to be the
Windows setup.

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx