OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 62303] New: Syntax error in documentation of Require expr (no quote needed)


https://bz.apache.org/bugzilla/show_bug.cgi?id=62303

            Bug ID: 62303
           Summary: Syntax error in documentation of Require expr (no
                    quote needed)
           Product: Apache httpd-2
           Version: 2.4.10
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: minor
          Priority: P2
         Component: mod_authz_core
          Assignee: bugs@xxxxxxxxxxxxxxxx
          Reporter: romain@xxxxxxxxxxx
  Target Milestone: ---

Hi

The documentation of Require expr syntax
(https://httpd.apache.org/docs/current/fr/mod/mod_authz_core.html#requiredirectives)
contain an error.

If using this example :

    Require expr "!(%{QUERY_STRING} =~ /secret/)"

Apache startup fail with this message 

    Cannot parse expression in require line: syntax error, unexpected $end

The correct syntax should be :

    Require expr !(%{QUERY_STRING} =~ /secret/)

(Same without double quote)

Apache version : Apache/2.4.10 (Debian)
Running in docker container.

Thank you for all your great work.

Regards

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx