osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 61613] New: Facing issue to start Apache after upgrading to 2.4.28 -libssl.so.1.1: cannot open shared object file: No such file or directory


https://bz.apache.org/bugzilla/show_bug.cgi?id=61613

            Bug ID: 61613
           Summary: Facing issue to start Apache after upgrading to 2.4.28
                    -libssl.so.1.1: cannot open shared object file: No
                    such file or directory
           Product: Apache httpd-2
           Version: 2.4.27
          Hardware: Other
                OS: Linux
            Status: NEW
          Severity: major
          Priority: P2
         Component: mod_ssl
          Assignee: bugs@xxxxxxxxxxxxxxxx
          Reporter: AL00339146@xxxxxxxxxxxxxxxx
  Target Milestone: ---

I am getting following error to start Apache service after upgrading Apache
httpd from 2.4.27 to 2.4.28.

httpd: Syntax error on line 130 of
/opt/SP/apache/httpd_current/conf/httpd.conf: Cannot load modules/mod_ssl.so
into server: libssl.so.1.1: cannot open shared object file: No such file or
directory

Below dependency packages for Apache 2.4.28 are installed:

OpenSSL 1.0.2j
Apr-1.6.2
Apr-util-1.6.0
Pcre-8.41

It is unable to find libssl.so.1.1 and libcrypto.so.1.1. While in Apache httpd
2.4.27 this two library files were not required.


[apache@ ~]$ ldd /opt/SP/apache/httpd_current/modules/mod_ssl.so
        linux-vdso.so.1 =>  (0x00007ffe9cf2e000)
        libssl.so.1.1 => not found
        libcrypto.so.1.1 => not found
        librt.so.1 => /lib64/librt.so.1 (0x00007faa35def000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00007faa35bb8000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x00007faa3599b000)
        libdl.so.2 => /lib64/libdl.so.2 (0x00007faa35797000)
        libc.so.6 => /lib64/libc.so.6 (0x00007faa353d4000)
        libfreebl3.so => /lib64/libfreebl3.so (0x00007faa351d0000)
        /lib64/ld-linux-x86-64.so.2 (0x00007faa3624d000)


Could you please check for this issue. Is this related to the recent changes
related to mod_ssl, ab: Fix compatibility with LibreSSL.  PR 61184.


Thanks and Regards,
Aakash Lodha

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx