osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 61551] Event MPM workers stuck in Gracefully Finishing with no connections left


https://bz.apache.org/bugzilla/show_bug.cgi?id=61551

--- Comment #4 from Nic Jansma <nic@xxxxxxxx> ---
Hi Luca,

Good idea.  I disabled mod_http2 (commented out #LoadModule) and verified it's
not being loaded anymore via httpd -M.

Unfortunately I'm still seeing the same behavior.  After a "reload" of httpd, I
see multiple PIDs stuck in Stopping "yes (old gen)" with 0 connections.  These
processes haven't exited for several hours.

I've done several "reload"s today.  Sometimes the old processes will transition
to Stopping and then exit.  Sometimes those processes will hang around forever.
 I currently have 4 processes in "yes (old gen)":

Slot    PID     Stopping        Connections     Threads Async connections
total   accepting       busy    idle    writing keep-alive      closing
0       31094   yes (old gen)   64      no      0       0       0       0      
0
1       26989   yes (old gen)   27      no      0       0       0       0      
0
2       21910   yes (old gen)   83      no      0       0       0       0      
0
3       31289   yes (old gen)   45      no      0       0       0       0      
0
5       3085    no      6       yes     2       62      0       6       0
8       3086    no      5       yes     0       64      0       5       0
9       3089    no      41      yes     4       60      0       30      8
Sum     7       4       271             6       186     0       41      8

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx