osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 61142] New: mod_proxy_wstunnel to upgrade to any protocol dynamically


https://bz.apache.org/bugzilla/show_bug.cgi?id=61142

            Bug ID: 61142
           Summary: mod_proxy_wstunnel to upgrade to any protocol
                    dynamically
           Product: Apache httpd-2
           Version: 2.5-HEAD
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: mod_proxy_wstunnel
          Assignee: bugs@xxxxxxxxxxxxxxxx
          Reporter: jbaesner@xxxxxxxxxx
  Target Milestone: ---

I'm trying to use Apache httpd 2.4.x in order to proxy incoming connection to
another IP/Port used by Wildfly 11 that listens to an upgraded http connection.

In this specific case I'm trying to proxy a remote JMS invocation. Here more
than one connection are being used by the "framework" code, each having a
different "upgrade".

The first request has the upgrade 'jboss-remoting' whereas the second request
has the upgrade 'activemq-remoting'. This is due to the fact that the initial
request is made by the JBoss remoting and the next request is then being
handled by netty from the messaging sub-system 'ActiveMQ'...

So what is needed is a dynamic upgrade to the protocol in the header.

I'll provide a way to reproduce it later, as there're currently some errors in
the community projects...

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx