osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[Bug 61097] New: Your APR doe not include SSL


https://bz.apache.org/bugzilla/show_bug.cgi?id=61097

            Bug ID: 61097
           Summary: Your APR doe not include SSL
           Product: Apache httpd-2
           Version: 2.4.25
          Hardware: PC
                OS: Linux
            Status: NEW
          Severity: normal
          Priority: P2
         Component: Build
          Assignee: bugs@xxxxxxxxxxxxxxxx
          Reporter: bensonward2@xxxxxxxxx
  Target Milestone: ---

When I build apache 2.4.25, I build pcre, apr and apr util 1.5.2 without issue.
When httpd builds it complains "Your APR does not include SSL/EVP support. To
enable it: configure --with-crypto." The terminal output is below.  And here is
the linked httpd as reported by ldd. I dont see anything related to ssl,
--with-crypto is not recognized by 'configure' either. Apache 2.2.32 seems to
get it right, but I dont know how to get 2.4.25 to do it. Here are the config
args I use...

configure --prefix="$TARGET" --with-apr=$TARGET --with-apr-util=$TARGET
--with-pcre=$TARGET --with-mpm=worker --enable-ssl=shared --enable-ssl
--with-ssl=/usr/lib64 --enable-proxy --enable-proxy-connect  --enable-proxy-ftp
 --enable-proxy-http --enable-headers --enable-expires > configureoutput.out


       linux-vdso.so.1 =>  (0x00007ffe40594000)
        libpcre.so.1 => /apps/apache/apache-httpd.2.4.25/lib/libpcre.so.1
(0x00007fb19f916000)
        libaprutil-1.so.0 =>
/apps/apache/apache-httpd.2.4.25/lib/libaprutil-1.so.0 (0x00007fb19f6f0000)
        libexpat.so.0 => /apps/apache/apache-httpd.2.4.25/lib/libexpat.so.0
(0x00007fb19f4c9000)
        libapr-1.so.0 => /apps/apache/apache-httpd.2.4.25/lib/libapr-1.so.0
(0x00007fb19f296000)
        librt.so.1 => /lib64/librt.so.1 (0x000000359ea00000)
        libcrypt.so.1 => /lib64/libcrypt.so.1 (0x00000035a4600000)
        libpthread.so.0 => /lib64/libpthread.so.0 (0x000000359e600000)
        libc.so.6 => /lib64/libc.so.6 (0x000000359de00000)
        /lib64/ld-linux-x86-64.so.2 (0x000000359da00000)
        libfreebl3.so => /lib64/libfreebl3.so (0x00000035a4e00000)
        libdl.so.2 => /lib64/libdl.so.2 (0x000000359e200000)


Checking pcre pkg
building pcre pkg for /apps/apache/apache-httpd.2.4.25
libtool: warning: relinking 'libpcreposix.la'
Checking apr
building apr for /apps/apache/apache-httpd.2.4.25
rm: cannot remove `conftest*': No such file or directory
rm: cannot remove `conftest*': No such file or directory
rm: cannot remove `libtoolT': No such file or directory
mkdir /apps/apache/apache-httpd.2.4.25/build-1
mkdir /apps/apache/apache-httpd.2.4.25/include/apr-1
Checking apr-util
building apr-util for /apps/apache/apache-httpd.2.4.25
configure: error: unrecognized option: `--with=-crypto'
Try `./configure --help' for more information
libtool: install: warning: relinking `libaprutil-1.la'
building http for /apps/apache/apache-httpd.2.4.25
configure: WARNING: apr/apr-util is compiled without ldap support
configure: WARNING: apr/apr-util is compiled without ldap support
configure: WARNING: Your APR does not include SSL/EVP support. To enable it:
configure --with-crypto
configure: WARNING: nghttp2 version is too old

-- 
You are receiving this mail because:
You are the assignee for the bug.
---------------------------------------------------------------------
To unsubscribe, e-mail: bugs-unsubscribe@xxxxxxxxxxxxxxxx
For additional commands, e-mail: bugs-help@xxxxxxxxxxxxxxxx