OSDir

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Commented] (GERONIMO-6604) Geronimo JWT Auth uses CDI 2.0 (must be 1.2)


    [ https://issues.apache.org/jira/browse/GERONIMO-6604?page=com.atlassian.jira.plugin.system.issuetabpanels:comment-tabpanel&focusedCommentId=16447615#comment-16447615 ] 

Romain Manni-Bucau commented on GERONIMO-6604:
----------------------------------------------

Hi Rudy,

It was (originally) intended to use CDI 2 - and it is fine for MP since 1.2 is just a min version as in any spec - but I opened a thread on dev@ to know if we want to solve it ([http://apache-geronimo.328035.n3.nabble.com/jwt-auth-CDI-base-version-td3991324.html).] 

Rational was that almost all vendors have a cdi 2 server now and it saves some boilerplate code so shouldn't be a big blocker but I understand the wildfly case so will wait for some feedback and if people push this ticket we'll fix it add BeanImpls - if you want to do a PR+answer the thread it can make it faster to be adopted too ;).

 

Thanks a lot to have tested BTW!

Romain

 

> Geronimo JWT Auth uses CDI 2.0 (must be 1.2)
> --------------------------------------------
>
>                 Key: GERONIMO-6604
>                 URL: https://issues.apache.org/jira/browse/GERONIMO-6604
>             Project: Geronimo
>          Issue Type: Wish
>      Security Level: public(Regular issues) 
>            Reporter: Rudy De Busscher
>            Priority: Major
>
> When adding the 
> {code:java}
> geronimo-jwt-auth-impl{code}
> to WildFLy 10.x, the 
> {code:java}
> GeronimoJwtAuthExtension{code}
> is not executed due to the fact is makes references to CDI 2.0.
>  
> Microprofile depends on CDI 1.2, so using 2.0 is wrong.
>  
>  



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)