osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Created] (FLINK-10324) Replace ZooKeeperStateHandleStore#getAllSortedByNameAndLock by getAllAndLock


Till Rohrmann created FLINK-10324:
-------------------------------------

             Summary: Replace ZooKeeperStateHandleStore#getAllSortedByNameAndLock by getAllAndLock
                 Key: FLINK-10324
                 URL: https://issues.apache.org/jira/browse/FLINK-10324
             Project: Flink
          Issue Type: Improvement
          Components: Distributed Coordination
    Affects Versions: 1.7.0
            Reporter: Till Rohrmann
            Assignee: Till Rohrmann
             Fix For: 1.7.0


In order to reduce code duplication I propose to replace {{ZooKeeperStateHandleStore#getAllSortedByNameAndLock}} by {{ZooKeeperStateHandleStore#getAllAndLock}} and sort afterwards.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)