OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Error when running Test on Fims


Hello Mark,

Thanks very much for your quick reply.

Here is the link to the PR having the error:
https://github.com/apache/fineract-cn-fims-web-app/pull/12

I have added the MatSelectModule into the imports of the TestingModule but
I still have the same error after running the test.

Thanks
Ruphine Kengne


On Thu, 25 Oct 2018 at 09:27, Mark van Veen <mark.vanveen@xxxxxxxxx> wrote:

> It looks like the test in available-actions.service.spec.ts does pull in a
> component which is using the MatSelect component. This is weird since its a
> unit test for a service which should not have any references to a component
> itself.
>
> Do you have a branch/fork/PR to share? So I can have a look and add my
> comments.
>
> BTW - the solution would be to add the MatSelectModule into the imports of
> the TestingModule but it would be good to understand why the component is
> being pulled in first.
>
> On Mon, Oct 22, 2018 at 7:09 PM Ruphine Kengne <ruphinekengne@xxxxxxxxx>
> wrote:
>
> > Hello everyone,
> >
> > I wrote unit test for the Group service into fims-web-app, it worked
> > successful
> > but I am having an error from the AvailableActionService in the teller
> > service when I run npm run test.
> >
> > Here is the link to the error:
> > https://pastebin.com/9ftKYDg8
> >
> > Here is the link to the commit for the issue FINCN-100(Write Unit test
> for
> > the Group service into fims):
> >
> >
> https://github.com/kengneruphine/fineract-cn-fims-web-app/commit/a2355be72c8bbd0cdfc86a6fdbdeb8d9be5c2f99
> >
> > Please can someone help me out?
> >
> > Thanks
> > Ruphine Kengne
> >
>