osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Fineract CN - UI build issues


Thanks Kelvin. Feedback is helpful.

Let me try and see if i can find the issue for ng build --prod.

I will raise the PR in couple of days.

Regards,
Karthik.

On Fri, Oct 12, 2018 at 11:52 AM Kelvin Ikome <kvnikome@xxxxxxxxx> wrote:

> Hello Kathik,
>
> I have tried the solution you came up with and it works when I build using
> "npm run build". However, I still get the same error when I try to build
> using "ng build --prod".
>
> Please send a pull request for the fix you did and take a look at this
> issue on Jira (https://issues.apache.org/jira/browse/FINCN-96?filter=-2)
> related to this bug.
>
> Thanks
>
> On Fri, Oct 5, 2018 at 3:51 PM Ruphine Kengne <ruphinekengne@xxxxxxxxx>
> wrote:
>
> > Hello Karthik,
> >
> > I have done those changes to the package.json file but it did not solve
> the
> > build error in my case.
> >
> > Since yours worked, Please can you sent a PR for it to be merge so that I
> > can pull ??
> >
> > Thanks
> > Ruphine Kengne
> >
> > On Fri, 5 Oct 2018 at 14:17, Karthik Ananthakrishnan
> > <karthik.a@xxxxxxxxxxxxxxxx.invalid> wrote:
> >
> > > Hello all,
> > >
> > > We made this below change in package.json and build worked.
> > >
> > > Before
> > > "runProd": "ng serve --proxy-config proxy.conf.json --prod",
> > >  "build": "ng build --prod",
> > >
> > > After
> > > "runProd": "ng serve --proxy-config proxy.conf.json
> > *--environment=prod*",
> > > "build": "ng build *--environment=prod*",
> > >
> > > For people who are facing UI build error, please check.
> > >
> > > Thanks,
> > > Karthik
> > >
> > > On Fri, Sep 28, 2018 at 9:18 PM Karthik Ananthakrishnan <
> > > karthik.a@xxxxxxxxxxxxxxxx> wrote:
> > >
> > > >
> > > >
> > >
> >
> https://user-images.githubusercontent.com/33152020/46206285-1f497b00-c341-11e8-9fe9-4fdc43ecb88e.png
> > > >
> > > > Image is attached in the git branch. Link is given above.
> > > >
> > > > Regards,
> > > > Karthik
> > > >
> > > > On Fri, Sep 28, 2018 at 5:46 PM Awasum Yannick <
> > > > awasum.yannick@xxxxxxxxxxxxx> wrote:
> > > >
> > > >> Hey Karthik,
> > > >>
> > > >> This list seems not to take attachments or pictures. Can you link
> the
> > > >> error
> > > >> to an external service and use url here?
> > > >> Or just paste the error in the email body.
> > > >>
> > > >>
> > > >> Thanks.
> > > >>
> > > >> On Fri, Sep 28, 2018 at 1:01 PM Karthik Ananthakrishnan
> > > >> <karthik.a@xxxxxxxxxxxxxxxx.invalid> wrote:
> > > >>
> > > >> > Hello All,
> > > >> >
> > > >> > I tried running the "build" command from the latest fims-web-app
> > > branch
> > > >> > and i am getting the following error. Is anyone facing this and
> have
> > > >> > resolved the issue?
> > > >> >
> > > >> > [image: UI_Build_Error.png]
> > > >> >
> > > >>
> > > >
> > >
> >
>