osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Failing 'Bundler Install'


Adding +Dev

On Fri 15 Jun, 2018, 4:48 PM Santosh Math, <santosh@xxxxxxxxxxxxxxxxxxxxxxx>
wrote:

> Hi Mohit and All,
>
> I am setting up Community-app(develop branch)  in my local
> machine(Ubuntu)  and after running 'bundler install'  I am getting  the
> following error.(prior this I successfully installed ruby-bundler)
>
> Installing ffi 1.9.25 with native extensions
> Gem::Ext::BuildError: ERROR: Failed to build gem native extension.
>
> current directory:
> /tmp/bundler20180615-6006-vdxicaffi-1.9.25/gems/ffi-1.9.25/ext/ffi_c
> /usr/bin/ruby2.5 -r ./siteconf20180615-6006-fgcx40.rb extconf.rb
> mkmf.rb can't find header files for ruby at /usr/lib/ruby/include/ruby.h
>
> extconf failed, exit code 1
>
> Gem files will remain installed in
> /tmp/bundler20180615-6006-vdxicaffi-1.9.25/gems/ffi-1.9.25 for inspection.
> Results logged to
>
> /tmp/bundler20180615-6006-vdxicaffi-1.9.25/extensions/x86_64-linux/2.5.0/ffi-1.9.25/gem_make.out
>
> An error occurred while installing ffi (1.9.25), and Bundler cannot
> continue.
> Make sure that `gem install ffi -v '1.9.25'` succeeds before bundling.
> --
> Thanks & Regards
>
> Santosh Math
>
> *QA Engineer*
>
> *Conflux Technologies Pvt Ltd <http://www.confluxtechnologies.com/>*
> | *Office*: +91-080-41208662 |
>
> *Address*: #304, 2nd Floor, 7th Main Road, HRBR Layout 1st Block,
> Bengaluru, Karnataka, 560043 INDIA
>