OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: [All] japicmp (parent 46)


Pardon I meant: http://commons.apache.org/releases/prepare.html#Create_the_Release_Candidate_with_the_Commons_Release_Plugin.

> On Apr 19, 2018, at 10:54 AM, Rob Tompkins <chtompki@xxxxxxxxx> wrote:
> 
> Give this a read:
> 
> http://commons.apache.org/releases/prepare.html#Create_the_Release_Candidate_with_the_Commons_Release_Plugin
> 
> I think that covers it. 
> 
> -Rob
> 
>> On Apr 19, 2018, at 10:42 AM, Gary Gregory <garydgregory@xxxxxxxxx> wrote:
>> 
>>> On Thu, Apr 19, 2018 at 8:24 AM, Rob Tompkins <chtompki@xxxxxxxxx> wrote:
>>> 
>>> 
>>> 
>>>> On Apr 19, 2018, at 10:20 AM, Gary Gregory <garydgregory@xxxxxxxxx>
>>> wrote:
>>>> 
>>>> Have the new build/release plugins been integrated in the docs?
>>>> https://commons.apache.org/releases/index.html
>>>> 
>>> 
>>> Working on that.
>>> 
>> 
>> Thank you Rob!
>> 
>> Gary
>> 
>> 
>>> 
>>>> I'd like to cut some RCs but I'd prefer to follow some docs.
>>>> 
>>>> Gary
>>>> 
>>>> On Thu, Apr 19, 2018 at 7:29 AM, Gilles <gilles@xxxxxxxxxxxxxxxxxxxxx>
>>>> wrote:
>>>> 
>>>>>> On Thu, 19 Apr 2018 09:17:45 -0400, Rob Tompkins wrote:
>>>>>> 
>>>>>> Try running package between “mvn“ and “site”
>>>>>> 
>>>>> 
>>>>> Not working.
>>>>> [And if it did, it would not be a "feature" (IMHO) wrt a simpler
>>>>> command line: If "package" is a dependency, it should be called
>>>>> automatically.]
>>>>> 
>>>>> Gilles
>>>>> 
>>>>> On Apr 19, 2018, at 9:13 AM, Gilles <gilles@xxxxxxxxxxxxxxxxxxxxx>
>>> wrote:
>>>>>>> 
>>>>>>> Hi.
>>>>>>> 
>>>>>>> $ mvn site site:stage
>>>>>>> 
>>>>>>> fails when there is no previous version:
>>>>>>> 
>>>>>>> ---CUT---
>>>>>>> [ERROR] Failed to execute goal org.apache.maven.plugins:
>>> maven-site-plugin:3.7:site
>>>>>>> (default-site) on project commons-geometry-core: Error generating
>>>>>>> japicmp-maven-plugin:0.11.1:cmp-report report: Failed to generate
>>>>>>> report: Please provide at least one resolvable old version using one
>>> of the
>>>>>>> configuration elements <oldVersion/> or <oldVersions/>. -> [Help 1]
>>>>>>> ---CUT---
>>>>>>> 
>>>>>>> Regards,
>>>>>>> Gilles
>>>>>>> 
>>>>>> 
>>>>> 
>>>>> ---------------------------------------------------------------------
>>>>> To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxxxxxx
>>>>> For additional commands, e-mail: dev-help@xxxxxxxxxxxxxxxxxx
>>>>> 
>>>>> 
>>> 
>>> ---------------------------------------------------------------------
>>> To unsubscribe, e-mail: dev-unsubscribe@xxxxxxxxxxxxxxxxxx
>>> For additional commands, e-mail: dev-help@xxxxxxxxxxxxxxxxxx
>>> 
>>>