[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: 4.9 to 4.11 upgrade broken


yes - please try the proper 4.11 systemvm templates.

> On Aug 21, 2018, at 1:54 PM, Asai <asai@xxxxxxxxxxxxxxxxxxxxx> wrote:
> 
> Can I manually download the systemvm template from here? http://download.cloudstack.org/systemvm/4.11/ <http://download.cloudstack.org/systemvm/4.11/>
> 
> Then manually overwrite it in the filesystem and update it accordingly in the database?
> 
> Asai
> 
> 
>> On Aug 21, 2018, at 1:40 PM, Asai <asai@xxxxxxxxxxxxxxxxxxxxx> wrote:
>> 
>> 4.11.0
>> 
>> As outlined in this http://docs.cloudstack.apache.org/projects/cloudstack-release-notes/en/4.11.0.0/upgrade/upgrade-4.9.html <http://docs.cloudstack.apache.org/projects/cloudstack-release-notes/en/4.11.0.0/upgrade/upgrade-4.9.html>
>>> On Aug 21, 2018, at 1:37 PM, ilya musayev <ilya.mailing.lists@xxxxxxxxx> wrote:
>>> 
>>> which template did you use? 
>>> 
>>>> On Aug 21, 2018, at 1:36 PM, Asai <asai@xxxxxxxxxxxxxxxxxxxxx> wrote:
>>>> 
>>>> Greetings,
>>>> 
>>>> I just tried to upgrade from 4.9 to 4.11, but it looks like the system VM template I downloaded according to the upgrade guide is the wrong template.  It’s 4.11, but I upgraded to 4.11.1 and I get this error message:
>>>> 
>>>> Caused by: com.cloud.utils.exception.CloudRuntimeException: 4.11.1.0KVM SystemVm template not found. Cannot upgrade system Vms
>>>> 	at com.cloud.upgrade.dao.Upgrade41100to41110.updateSystemVmTemplates(Upgrade41100to41110.java:281)
>>>> 	at com.cloud.upgrade.dao.Upgrade41100to41110.performDataMigration(Upgrade41100to41110.java:68)
>>>> 	at com.cloud.upgrade.DatabaseUpgradeChecker.upgrade(DatabaseUpgradeChecker.java:578)
>>>> 	... 53 more
>>>> 2018-08-21 13:28:25,257 INFO  [o.e.j.s.h.ContextHandler] (main:null) (logid:) Started o.e.j.s.h.MovedContextHandler@15bfd87{/,null,AVAILABLE}
>>>> 2018-08-21 13:28:25,317 INFO  [o.e.j.s.AbstractConnector] (main:null) (logid:) Started ServerConnector@4b1c1ea0{HTTP/1.1,[http/1.1]}{:::8080}
>>>> 2018-08-21 13:28:25,318 INFO  [o.e.j.s.Server] (main:null) (logid:) Started @20725ms
>>>> 
>>>> Can anyone assist with getting this corrected?
>>>> 
>>>> Thank you,
>>>> Asai
>>>> 
>>>> 
>>> 
>> 
>