osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Adding a static route to the SSVM for remote NFS server


Hi Sateesh


I was trying to edit the interfaces files on the SSVM itself, I would never have thought to use that setting.


Worked perfectly, many thanks for that, much appreciated.


Jon


________________________________
From: Sateesh Chodapuneedi <sateesh.chodapuneedi@xxxxxxxxxxxxxx>
Sent: 27 June 2018 10:58
To: users@xxxxxxxxxxxxxxxxxxxxx
Subject: Re: Adding a static route to the SSVM for remote NFS server

Hi Jon,

>> Do you know how to add it permanently across reboots ?
Yes, we can update the global configuration setting "secstorage.allowed.internal.sites" to achieve that. That is a comma separated list of internal CIDRs having the servers hosting the templates that SSVM tries to download. We can add the CIDR of NFS server over there, just add the CIDR in that comma separated list. Do not overwrite whatever is the current setting, just append after a comma.

Regards,
Sateesh

-----Original Message-----
From: Jon Marshall <jms.123@xxxxxxxxxxxxx>
Reply-To: "users@xxxxxxxxxxxxxxxxxxxxx" <users@xxxxxxxxxxxxxxxxxxxxx>
Date: Wednesday, 27 June 2018 at 13:45
To: "users@xxxxxxxxxxxxxxxxxxxxx" <users@xxxxxxxxxxxxxxxxxxxxx>
Subject: Re: Adding a static route to the SSVM for remote NFS server

    Hi Sateesh


    I can add the route manually but when the SSVM is rebooted it loses that route.


    I edited the /etc/network/interfaces file and added it there but it still gets overwritten on reboot.


    Do you know how to add it permanently across reboots ?

    Jon
    ________________________________
    From: Sateesh Chodapuneedi <sateesh.chodapuneedi@xxxxxxxxxxxxxx>
    Sent: 26 June 2018 16:25
    To: users@xxxxxxxxxxxxxxxxxxxxx
    Subject: Re: Adding a static route to the SSVM for remote NFS server

    Hi Jon,

    >> Can I just add a static route to the SSVM for the 172.30.5.0/28 subnet and would this work or is there a better way to do it ?

    Yes, that should work. I did it some time back in my environment where NFS server is sitting in a separate subnet (in LAN), and public NIC/gateway in the SSVM was used to route the packets to/fro NFS server. We have added static route via the private/management NIC because the NFS server sits in LAN.
    Let us know how it goes.

    Regards,
    Sateesh

    -----Original Message-----
    From: Jon Marshall <jms.123@xxxxxxxxxxxxx>
    Reply-To: "users@xxxxxxxxxxxxxxxxxxxxx" <users@xxxxxxxxxxxxxxxxxxxxx>
    Date: Tuesday, 26 June 2018 at 19:36
    To: "users@xxxxxxxxxxxxxxxxxxxxx" <users@xxxxxxxxxxxxxxxxxxxxx>
    Subject: Adding a static route to the SSVM for remote NFS server

        I am doing basic networking with 2 NICS (one for management/storage and the other for Guest traffic).

        When you configure the physical NIC/bridges  you can only define one default gateway so I do it for the guest traffic which means the routing table on the SSVM ends up as  -

        root@s-1-VM:/etc# netstat -nr
        Kernel IP routing table
        Destination     Gateway         Genmask         Flags   MSS Window  irtt Iface
        0.0.0.0         172.30.4.1      0.0.0.0         UG        0 0          0 eth2
        8.8.4.4         172.30.3.1      255.255.255.255 UGH       0 0          0 eth1
        8.8.8.8         172.30.3.1      255.255.255.255 UGH       0 0          0 eth1
        169.254.0.0     0.0.0.0         255.255.0.0     U         0 0          0 eth0
        172.30.3.0      0.0.0.0         255.255.255.192 U         0 0          0 eth1
        172.30.4.0      0.0.0.0         255.255.255.128 U         0 0          0 eth2


        where 172.30.3.0/26 is the management network and 172.30.4.0/25 is the guest network.

        My NFS server has an IP of 172.30.5.2 so it is on a different subnet which means the the secondary storage would have to run over the guest NIC if I am understanding this properly.

        I want storage over the management NIC.  Based on some advice on this mailing list I configured storage to use the same bridge (KVM label) as management but it won't build ie. it errors on the storage traffic part I suspect because the subnet details I enter are not part of the management subnet.

        Can I just add a static route to the SSVM for the 172.30.5.0/28 subnet and would this work or is there a better way to do it ?

        On a more general note with basic networking the assumption seems to be you run everything over the same NIC and if you don't it seems to cause no end of problems :)





    DISCLAIMER
    ==========
    This e-mail may contain privileged and confidential information which is the property of Accelerite, a Persistent Systems business. It is intended only for the use of the individual or entity to which it is addressed. If you are not the intended recipient, you are not authorized to read, retain, copy, print, distribute or use this message. If you have received this communication in error, please notify the sender and delete all copies of this message. Accelerite, a Persistent Systems business does not accept any liability for virus infected mails.