[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Isolated network VR


Hello All,


I downgraded one of my kvm to the version 1.5 from base depot.
i create one VR and its working fine with this qemu version.


The issue seems to come from the communication between KVM and guest via the vports


XML configuration on both VR are the same (except one line <alias name='channel0'/> in channel type = unix)


>From KVM side on netstat, we can see :

qemu/kvm 2.3 :

unix  2      [ ]         STREAM     CONNECTE      39748167 /var/lib/libvirt/qemu/r-73-VM.agent

unix  2      [ ]         STREAM     ENCONNEXION   0        /var/lib/libvirt/qemu/r-73-VM.agent


qemu/kvm 1.5:

unix  2      [ ]         STREAM     CONNECTE      38420851 /var/lib/libvirt/qemu/r-74-VM.agent


>From guest side (faulty VR) :

root@systemvm:/sys/kernel/debug/virtio-ports# cat vport3p1
name: r-73-VM.vport
guest_connected: 0
host_connected: 1
outvq_full: 0
bytes_sent: 0
bytes_received: 0
bytes_discarded: 0
is_console: no
console_vtermno: 0

>From guest side (good VR) :

root@systemvm:/sys/kernel/debug/virtio-ports# cat vport1p1

name: r-74-VM.vport

guest_connected: 0
host_connected: 1
outvq_full: 0
bytes_sent: 0
bytes_received: 864
bytes_discarded: 0
is_console: no
console_vtermno: 0

As we can see the working VR have "bytes_received" not the faulty one, i'm guessing the bytes correspond at the succes of the patchviasocket.py


Nicolas Bouige
DIMSI
cloud.dimsi.fr<http://www.cloud.dimsi.fr>
4, avenue Laurent Cely
Tour d’Asnière – 92600 Asnière sur Seine
T/ +33 (0)6 28 98 53 40


________________________________
De : Nicolas Bouige <n.bouige@xxxxxxxx>
Envoyé : mercredi 20 juin 2018 11:32:38
À : users@xxxxxxxxxxxxxxxxxxxxx
Objet : Isolated network VR

Hello All,


i'm facing a new issue with new VR creation (Guest network/VPC network)

it's look like the configuration is not push to the virtual router...


>From GUI web, creation is working fine except the router remains in state "starting"


log from KVM :

2018-06-19 16:10:18,020 WARN  [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-3:null) (logid:d9e07a00) Timed out: /usr/share/cloudstack-common/scripts/vm/hypervisor/kvm/patchviasocket.py -n r-256-VM -p %template=domP%name=r-256-VM%eth2ip=159.180.X.X%eth2mask=255.255.255.X%gateway=159.180.X.X%eth0ip=10.1.1.1%eth0mask=255.255.255.0%domain=cs5cloud.internal%cidrsize=24%dhcprange=10.1.1.1%eth1ip=169.254.0.148%eth1mask=255.255.0.0%type=router%disable_rp_filter=true%dns1=8.8.8.8%baremetalnotificationsecuritykey=BjMd_9Gs0da26DHEHBNAmSDK64_4s4rwhuNtiQY0vk3rpR1ICQelMbWgPI-YMA1PZxvH4hHDTgoDOKxw7AigkQ%baremetalnotificationapikey=QbcXriZUmi6z-hCAKIBswy47CenZYTvIbsYsYbfcWdQXn8iSEpjjQoarOKRWf4GDWJDUfdCs_pLH-bfCyTrxIg%host=172.8.X.X%port=8080 .  Output is:

2018-06-19 16:10:18,020 ERROR [kvm.resource.LibvirtComputingResource] (agentRequest-Handler-3:null) (logid:d9e07a00) passcmd failed:timeout


log from Virtual-Router (script can't detect the system-vm as a virtual-router):

Tue Jun 19 16:13:18 UTC 2018 Executing cloud-early-config

Tue Jun 19 16:13:18 UTC 2018 Detected that we are running inside kvm
Tue Jun 19 16:13:49 UTC 2018 Scripts checksum detected: oldmd5=3abb34cc8308c19c684676a7deaf86c8 newmd5=3abb34cc8308c19c684676a7deaf86c8
Tue Jun 19 16:13:49 UTC 2018 Configuring systemvm type=
Tue Jun 19 16:13:49 UTC 2018 Finished setting up systemvm

i updated qemu-kvm from qemu-kvm 1.5.3 to qemu-kvm-ev 2.3, do you think this version could be incompatible with CS 4.11 ?

QEMU emulator version 2.3.0 (qemu-kvm-ev-2.3.0-29.1.el7)

i made this update to perfom --quiesce backup of the VMs.


Best regards,

Nicolas Bouige
DIMSI
cloud.dimsi.fr<http://www.cloud.dimsi.fr>
4, avenue Laurent Cely
Tour d’Asnière – 92600 Asnière sur Seine
T/ +33 (0)6 28 98 53 40