OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: Cloudstack 4.11.1 RC1. SystemVM Config Issue with Xenserver 7.1. Detected as xen-domU.


Hi Paul

Thanks for your reply, it appears the SystemVM's are running as HVM - so those options are missing. 

Although is that the intended deployment since this commit?  https://github.com/apache/cloudstack/pull/2465#issuecomment-370807868 

Cheers

James Richards
Senior Systems Engineer

D: +441183654816
M: 448000000000.00
T: 0800 970 9292

www.pulsant.com


Pulsant is a limited company registered in England and Wales.

Registered number: 03625971. 
Registered office: Cadogan House, Rose Kiln Lane, Reading, Berks RG2 0HP.

Please note that Pulsant may monitor email traffic data and also the content of email for the purposes of security and staff training.

Email confidentiality notice
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. Any offers or quotation of service are subject to formal specification. Errors and omissions excepted. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of Pulsant Limited or any companies within the wider group. Finally, the recipient should check this email and any attachments for the presence of viruses. Pulsant Limited accept no liability for any damage caused by any virus transmitted by this email.


 

-----Original Message-----
From: Paul Angus <paul.angus@xxxxxxxxxxxxx> 
Sent: 04 June 2018 10:23
To: users@xxxxxxxxxxxxxxxxxxxxx
Subject: RE: Cloudstack 4.11.1 RC1. SystemVM Config Issue with Xenserver 7.1. Detected as xen-domU.

Hi James,

This looks like a slightly different issue as the system VM is not getting it’s config when booting. Can you look at the system VM through XenCenter, and look at the ‘Boot Options’ for that VM, are there ‘OS boot parameters’ shown there, something like:


OS boot parameters:      -- quiet console=hvc0%template=domP%type=secstorage%host=10.2.3.192%port=8250%name=s-2-VM%zone=1%pod=1%guid=s-2-VM%workers=10%resource=com.cloud.storage.resource.PremiumSecondaryStorageResource%instance=SecStorage%sslcopy=false%role=templateProcessor%mtu=1500%eth2ip=10.1.35.2%eth2mask=255.255.224.0%gateway=10.1.63.254%public.network.device=eth2%eth0ip=169.254.1.107%eth0mask=255.255.0.0%eth1ip=10.2.6.11%eth1mask=255.255.0.0%mgmtcidr=10.2.0.0/16%localgw=10.2.254.254%private.network.device=eth1%internaldns1=8.8.8.8%internaldns2=8.8.4.4%dns1=8.8.8.8%dns2=8.8.4.4%nfsVersion=null

Kind regards,

Paul Angus

From: James Richards <James.Richards@xxxxxxxxxxx>
Sent: 01 June 2018 13:01
To: users@xxxxxxxxxxxxxxxxxxxxx
Subject: Cloudstack 4.11.1 RC1. SystemVM Config Issue with Xenserver 7.1. Detected as xen-domU.

Hi

I’m attempting to integrate Cloudstack on top of Centos 7, with Xenserver 7.1 as the hypervisor.

Initially I came up against the problem described here, https://github.com/apache/cloudstack/issues/2561 . The SystemVM’s did not complete configuration, with the ‘systemvm type=’ observed within cloud.log.

I noticed the commit https://github.com/shapeblue/cloudstack/commit/8533def696dacb989b8fde17403bfca98e6139b0 is intended to the solve the issue.    So I rebuilt everything from scratch using Shape Blues 4.11.1 RC1 http://packages.shapeblue.com/testing/4111rc1/centos7/4.11/  with the SystemVM template from here.  http://packages.shapeblue.com/systemvmtemplate/4.11.1-rc1/

Despite using the 4.11.1 RC1 packages,  I am still having the same issue.

So within the cloud.log I still see

Executing cloud-early-config
Detected that we are running inside xen-domU Scripts checksum detected : oldmd5=***….
Patched scripts using media/cdrom/cloud-scripts.tgz Patching cloud service Configuring systemvm type= Finished setting up systemvm

That was typed out manually as I don’t have network access.. 😊

Any ideas what could be causing it and whether the probem is considered fixed in 4.11.1 RC1?

Any help would be greatly appreciated.

Regards

James Richards
Senior Systems Engineer

D: +441183654816
M: 448000000000.00
T: 0800 970 9292

pulsant.com<http://www.pulsant.com>

[Pulsant]<http://www.pulsant.com/>





Address: Pulsant - Cadogan House
Rose Kiln Lane, Reading, RG2 0HP

[Twitter]<https://facebook.com/Pulsant>

[Twitter]<https://twitter.com/PulsantUK>

[LinkedIn]<http://www.linkedin.com/company/2515168>

[YouTube]<http://www.youtube.com/user/PulsantUK>



Please note that Pulsant may monitor email traffic data and also the content of email for the purposes of security and staff training.

Email confidentiality notice
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the sender. Any offers or quotation of service are subject to formal specification. Errors and omissions excepted. Please note that any views or opinions presented in this email are solely those of the author and do not necessarily represent those of Pulsant Limited or any companies within the wider group. Finally, the recipient should check this email and any attachments for the presence of viruses. Pulsant Limited accept no liability for any damage caused by any virus transmitted by this email.

Pulsant is a limited company registered in England and Wales.
Registered number: 03625971.
Registered office: Cadogan House, Rose Kiln Lane, Reading, Berks RG2 0HP.

paul.angus@xxxxxxxxxxxxx
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK @shapeblue