OSDir

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Can't KVM migrate between local storage.


Hi Darius,

>From the logs, I could observe that image volume is already in the creating
state and trying to use the same for copying the volume between pools. So,
state transition failed. Could you please provide the complete log for the
usecase to root cause the issue. Also, include volumes and snapshots db
details for the mentioned volume and snapshot.

-Suresh


On Thu, May 10, 2018 at 1:22 PM, Daznis <daznis@xxxxxxxxx> wrote:

> Snapshots work fine. I can make a snapshot -> convert it to template
> and start the VM on a new node from that template. When I needed to
> move one VM for balance purposes. But I want to fix the migration
> process. I have attached the error log to this email. Maybe I'm
> looking at the wrong place were I get the error?
>
> On Wed, May 9, 2018 at 9:23 PM, Marc-Aurèle Brothier <marco@xxxxxxxxxxx>
> wrote:
> > Can you try to perform a snapshot of the volume on VM's that are on your
> > host, to see if they get copied correctly other the NFS too.
> >
> > Otherwise you need to look into the management logs to catch the
> exception
> > (stack trace) to have a better understanding of the issue.
> >
> > On Wed, May 9, 2018 at 1:58 PM, Daznis <daznis@xxxxxxxxx> wrote:
> >
> >> Hello,
> >>
> >>
> >> Yeah it's offline. I'm running 4.9.2 version. Running it on the same
> >> zone with the  only NFS secondary storage.
> >>
> >> On Wed, May 9, 2018 at 10:49 AM, Marc-Aurèle Brothier <
> marco@xxxxxxxxxxx>
> >> wrote:
> >> > Hi Darius,
> >> >
> >> > Are you trying to perform an offline migration within the same zone,
> >> > meaning that the source and destination hosts have the same set of NFS
> >> > secondary storage ?
> >> >
> >> > Marc-Aurèle
> >> >
> >> > On Tue, May 8, 2018 at 3:37 PM, Daznis <daznis@xxxxxxxxx> wrote:
> >> >
> >> >> Hi,
> >> >>
> >> >>
> >> >> I'm having an issue while migrating offline vm disk within local
> >> >> storages. The particular error that has be baffled is "Can't find
> >> >> staging storage in zone". From what I have gather "staging storage"
> >> >> referred to secondary storage in cloudstack and it's working
> perfectly
> >> >> fine with both the source and destination node. Not sure where to go
> >> >> next. Any help would be appreciated.
> >> >>
> >> >>
> >> >> Regards,
> >> >> Darius
> >> >>
> >>
>