OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

RE: ssvm NFS public ip


Hello All,

With this new deployement my ssvm is now okay.
I saw my mistake...the URLs were good for mgmt and systemvm template...but not for the cloudstack-agent installed on KVM...

Best regards,

N.B

-----Message d'origine-----
De : Nicolas Bouige [mailto:n.bouige@xxxxxxxx] 
Envoyé : jeudi 12 avril 2018 09:56
À : users@xxxxxxxxxxxxxxxxxxxxx
Objet : RE: ssvm NFS public ip

Hi Paul,

I used repository from shapeblue for mgmt-server and systemvm-template.
Im going to make a new fresh install (again :/) and double check the URL.

Thanks,

Best regards,
N.B


-----Message d'origine-----
De : Paul Angus [mailto:paul.angus@xxxxxxxxxxxxx] Envoyé : jeudi 12 avril 2018 09:12 À : users@xxxxxxxxxxxxxxxxxxxxx Objet : RE: ssvm NFS public ip

Hi Nicolas, this usually happens if you mix redist and noredist builds of mgmt. server and system vm code.

What URLs did you use for the management server repo and the system VM templates?



paul.angus@xxxxxxxxxxxxx
www.shapeblue.com
53 Chandos Place, Covent Garden, London  WC2N 4HSUK @shapeblue
  
 


-----Original Message-----
From: Nicolas Bouige <n.bouige@xxxxxxxx>
Sent: 11 April 2018 19:44
To: users@xxxxxxxxxxxxxxxxxxxxx
Subject: RE: ssvm NFS public ip

Hi ilya,


Thanks for your answer

Yes i did it already with no effect :/


Best regards,

N.B

________________________________
De : ilya musayev <ilya.mailing.lists@xxxxxxxxx> Envoyé : mercredi 11 avril 2018 20:26:34 À : users@xxxxxxxxxxxxxxxxxxxxx Objet : Re: ssvm NFS public ip

There is a global setting you have to set to use internal non public IP.

Try setting sec.storage.allow.internal.site to an internal network cidr.

You may need to destroy ssvm for settings to take effect. In my case there is some sort of minor bug where it takes upward of 5 minutes for ssvm to program the internal routes, but since this is onetime operation - I just live with it.

On Wed, Apr 11, 2018 at 10:50 AM Nicolas Bouige <n.bouige@xxxxxxxx> wrote:

> a small update about my problem.
>
> I 've recreated the zone from scratch this morning and  one of my 
> "cloudbr" used for the secondary storage was misconfigured.
>
> So Now, I can ping the secondary storage from KVM host, CS-MGMT,  SSVM 
> and mount the nfs on them...but...the agent still not going up and the 
> ssvm_check.sh give me an ip public for the nfs instead of the private.
>
>
> i got only this error in /var/log:cloud.log :
>
> 17:30:22,600 ERROR AgentShell:477 - Unable to start agent: Resource 
> class not found: com.cloud.storage.resource.PremiumSecondaryStorageResource due
> to: java.lan                            g.ClassNotFoundException:
> com.cloud.storage.resource.PremiumSecondaryStorageReso
>       urce
> Unable to start agent: Resource class not found:
> com.cloud.storage.resource.Prem
> iumSecondaryStorageResource due to: java.lang.ClassNotFoundException:
> com.cloud.
> storage.resource.PremiumSecondaryStorageResource
>
> i've tried to update a differente systemvm template with no success...
> I 've compared the configuration of the ssvm with one of our 
> deployment and i juste noticed the "resource"
> (org.apache.cloudstack.storage.resource.NfsSecondaryResource) was not 
> the same.
> i changed it but still the same error...
>
> There is a way to find java binaries/script and  upload them on the ssvm ?
>
> If one of you have an idea, it would be appreciate.
>
> Thanks !
>
> Best regards,
> N.B
>
>