osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Unable to build Avatica release: An API incompatibility was encountered while executing org.apache.maven.plugins:maven-release-plugin:2.5.3:prepare


Thanks, Michael!

Downgrading maven-scm-provider appears to fix the build. I will push a fix for this.

On 17/11/2018 1:22 am, Michael Mior wrote:
Looks like this is an issue with maven-scm-provider 1.11.1.

https://www.mail-archive.com/issues@xxxxxxxxxxxxxxxx/msg137630.html

A temporary solution seems to be to downgrade to 1.10.0.

--
Michael Mior
mmior@xxxxxxxxxx


Le ven. 16 nov. 2018 à 03:31, Francis Chuang <francischuang@xxxxxxxxxx> a
écrit :

Hi all,

I am trying to build an Avatica release. I am building from the latest
master (a8617e0354c50b006a6e098371179be99b6270eb).

The command used is:

mvn -Dmaven.artifact.threads=20 -DreleaseVersion=1.13.0
-DdevelopmentVersion=1.14.0 -Dtag="avatica-1.13.0-rc0" -Papache-release
-Duser.name=${username} release:prepare
-Darguments=-Dgpg.keyname=${selected_key}

This is the error from when building:

[ERROR] Failed to execute goal
org.apache.maven.plugins:maven-release-plugin:2.5.3:prepare
(default-cli) on project avatica-parent: Execution default-cli of goal
org.apache.maven.plugins:maven-release-plugin:2.5.3:prepare failed: An
API incompatibility was encountered while executing
org.apache.maven.plugins:maven-release-plugin:2.5.3:prepare:
java.lang.NoSuchMethodError:
org.apache.maven.scm.ScmTagParameters.isSign()Z
[ERROR] -----------------------------------------------------
[ERROR] realm = plugin>org.apache.maven.plugins:maven-release-plugin:2.5.3
[ERROR] strategy =
org.codehaus.plexus.classworlds.strategy.SelfFirstStrategy
[ERROR] urls[0] =

file:/root/.m2/repository/org/apache/maven/plugins/maven-release-plugin/2.5.3/maven-release-plugin-2.5.3.jar
[ERROR] urls[1] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-gitexe/1.11.1/maven-scm-provider-gitexe-1.11.1.jar
[ERROR] urls[2] =
file:/root/.m2/repository/commons-io/commons-io/2.6/commons-io-2.6.jar
[ERROR] urls[3] =

file:/root/.m2/repository/commons-lang/commons-lang/2.6/commons-lang-2.6.jar
[ERROR] urls[4] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-git-commons/1.11.1/maven-scm-provider-git-commons-1.11.1.jar
[ERROR] urls[5] =

file:/root/.m2/repository/org/apache/maven/release/maven-release-manager/2.5.3/maven-release-manager-2.5.3.jar
[ERROR] urls[6] =

file:/root/.m2/repository/org/apache/maven/release/maven-release-api/2.5.3/maven-release-api-2.5.3.jar
[ERROR] urls[7] =

file:/root/.m2/repository/org/eclipse/aether/aether-util/1.0.0.v20140518/aether-util-1.0.0.v20140518.jar
[ERROR] urls[8] =
file:/root/.m2/repository/junit/junit/3.8.1/junit-3.8.1.jar
[ERROR] urls[9] =

file:/root/.m2/repository/org/codehaus/plexus/plexus-interactivity-api/1.0-alpha-6/plexus-interactivity-api-1.0-alpha-6.jar
[ERROR] urls[10] =

file:/root/.m2/repository/org/codehaus/plexus/plexus-interpolation/1.14/plexus-interpolation-1.14.jar
[ERROR] urls[11] =

file:/root/.m2/repository/org/sonatype/plexus/plexus-sec-dispatcher/1.3/plexus-sec-dispatcher-1.3.jar
[ERROR] urls[12] =

file:/root/.m2/repository/org/sonatype/plexus/plexus-cipher/1.4/plexus-cipher-1.4.jar
[ERROR] urls[13] =

file:/root/.m2/repository/backport-util-concurrent/backport-util-concurrent/3.1/backport-util-concurrent-3.1.jar
[ERROR] urls[14] =

file:/root/.m2/repository/org/apache/maven/shared/maven-invoker/2.2/maven-invoker-2.2.jar
[ERROR] urls[15] =

file:/root/.m2/repository/org/codehaus/plexus/plexus-component-annotations/1.5.5/plexus-component-annotations-1.5.5.jar
[ERROR] urls[16] =
file:/root/.m2/repository/commons-cli/commons-cli/1.2/commons-cli-1.2.jar
[ERROR] urls[17] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-providers-standard/1.9.4/maven-scm-providers-standard-1.9.4.pom
[ERROR] urls[18] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-accurev/1.9.4/maven-scm-provider-accurev-1.9.4.jar
[ERROR] urls[19] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-bazaar/1.9.4/maven-scm-provider-bazaar-1.9.4.jar
[ERROR] urls[20] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-clearcase/1.9.4/maven-scm-provider-clearcase-1.9.4.jar
[ERROR] urls[21] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-cvsexe/1.9.4/maven-scm-provider-cvsexe-1.9.4.jar
[ERROR] urls[22] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-cvs-commons/1.9.4/maven-scm-provider-cvs-commons-1.9.4.jar
[ERROR] urls[23] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-cvsjava/1.9.4/maven-scm-provider-cvsjava-1.9.4.jar
[ERROR] urls[24] =

file:/root/.m2/repository/org/netbeans/lib/cvsclient/20060125/cvsclient-20060125.jar
[ERROR] urls[25] =

file:/root/.m2/repository/ch/ethz/ganymed/ganymed-ssh2/build210/ganymed-ssh2-build210.jar
[ERROR] urls[26] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-hg/1.9.4/maven-scm-provider-hg-1.9.4.jar
[ERROR] urls[27] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-perforce/1.9.4/maven-scm-provider-perforce-1.9.4.jar
[ERROR] urls[28] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-starteam/1.9.4/maven-scm-provider-starteam-1.9.4.jar
[ERROR] urls[29] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-svnexe/1.9.4/maven-scm-provider-svnexe-1.9.4.jar
[ERROR] urls[30] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-synergy/1.9.4/maven-scm-provider-synergy-1.9.4.jar
[ERROR] urls[31] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-vss/1.9.4/maven-scm-provider-vss-1.9.4.jar
[ERROR] urls[32] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-tfs/1.9.4/maven-scm-provider-tfs-1.9.4.jar
[ERROR] urls[33] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-integrity/1.9.4/maven-scm-provider-integrity-1.9.4.jar
[ERROR] urls[34] =

file:/root/.m2/repository/com/mks/api/mksapi-jar/4.10.9049/mksapi-jar-4.10.9049.jar
[ERROR] urls[35] =

file:/root/.m2/repository/org/codehaus/groovy/groovy-all/1.7.6/groovy-all-1.7.6.jar
[ERROR] urls[36] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-jazz/1.9.4/maven-scm-provider-jazz-1.9.4.jar
[ERROR] urls[37] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-manager-plexus/1.8/maven-scm-manager-plexus-1.8.jar
[ERROR] urls[38] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-provider-svn-commons/1.9.4/maven-scm-provider-svn-commons-1.9.4.jar
[ERROR] urls[39] =
file:/root/.m2/repository/jaxen/jaxen/1.1-beta-8/jaxen-1.1-beta-8.jar
[ERROR] urls[40] = file:/root/.m2/repository/jdom/jdom/1.0/jdom-1.0.jar
[ERROR] urls[41] =
file:/root/.m2/repository/org/slf4j/slf4j-jdk14/1.5.6/slf4j-jdk14-1.5.6.jar
[ERROR] urls[42] =

file:/root/.m2/repository/org/slf4j/jcl-over-slf4j/1.5.6/jcl-over-slf4j-1.5.6.jar
[ERROR] urls[43] =

file:/root/.m2/repository/org/apache/maven/reporting/maven-reporting-api/2.2.1/maven-reporting-api-2.2.1.jar
[ERROR] urls[44] =

file:/root/.m2/repository/org/apache/maven/doxia/doxia-sink-api/1.1/doxia-sink-api-1.1.jar
[ERROR] urls[45] =

file:/root/.m2/repository/org/apache/maven/doxia/doxia-logging-api/1.1/doxia-logging-api-1.1.jar
[ERROR] urls[46] =

file:/root/.m2/repository/org/apache/maven/scm/maven-scm-api/1.9.4/maven-scm-api-1.9.4.jar
[ERROR] urls[47] =

file:/root/.m2/repository/org/codehaus/plexus/plexus-utils/3.0.15/plexus-utils-3.0.15.jar
[ERROR] urls[48] = file:/root/.m2/repository/org/jdom/jdom/1.1/jdom-1.1.jar
[ERROR] Number of foreign imports: 1
[ERROR] import: Entry[import  from realm
ClassRealm[project>org.apache.calcite.avatica:avatica-parent:1.13.0-SNAPSHOT,

parent: ClassRealm[maven.api, parent: null]]]
[ERROR]
[ERROR] -----------------------------------------------------
[ERROR]
[ERROR] -> [Help 1]
[ERROR]
[ERROR] To see the full stack trace of the errors, re-run Maven with the
-e switch.
[ERROR] Re-run Maven using the -X switch to enable full debug logging.
[ERROR]
[ERROR] For more information about the errors and possible solutions,
please read the following articles:
[ERROR] [Help 1]
http://cwiki.apache.org/confluence/display/MAVEN/PluginContainerException

This does not happen when I use `-DdryRun`. Can someone please take a
look at this?

Francis