osdir.com

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[jira] [Created] (CALCITE-2594) Ensure forbiddenapis and maven-compiler use the correct JDK version


Kevin Risden created CALCITE-2594:
-------------------------------------

             Summary: Ensure forbiddenapis and maven-compiler use the correct JDK version
                 Key: CALCITE-2594
                 URL: https://issues.apache.org/jira/browse/CALCITE-2594
             Project: Calcite
          Issue Type: Bug
          Components: avatica, core
            Reporter: Kevin Risden
            Assignee: Kevin Risden
             Fix For: avatica-1.13.0, 1.18.0


I was looking at the build logs the other day for Avatica and noticed the following:
{noformat}
[INFO] --- forbiddenapis:2.6:testCheck (default) @ avatica-core ---
[INFO] Scanning for classes to check...
[INFO] Reading bundled API signatures: jdk-unsafe-1.7
[INFO] Reading bundled API signatures: jdk-deprecated-1.7{noformat}
The 1.7 being the JDK version that forbiddenapis is picking up for the signatures. I double checked that we were setting the compiler to use JDK 8 and moved on.

Today I was looking at the ASF POM for a different project and noticed:
{code:java}
<maven.compiler.source>1.7</maven.compiler.source>
<maven.compiler.target>1.7</maven.compiler.target>
{code}
I double checked the forbiddenapis docs and those two properties are used to determine the correct signatures.

This Jira is to override the base ASF POM properties in the top level pom to be the following:
{code:java}
<maven.compiler.source>8</maven.compiler.source>
<maven.compiler.target>8</maven.compiler.target>
{code}
After making that change locally I can see forbiddenapis picking up the correct signatures.



--
This message was sent by Atlassian JIRA
(v7.6.3#76005)