OSDir


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Calcite travis jdk11 failed while compilation of calcite-elasticsearch2 on travis


PS Can someone please log a JIRA case for this. At the very least we need to modify HISTORY.md to say which ES versions are supported with each JDK. If we can make a code fix, even better.

> On Jun 12, 2018, at 3:14 PM, Julian Hyde <jhyde@xxxxxxxxxx> wrote:
> 
> What would be the command-line arguments to achieve this? I will add them to my nightly build scripts.
> 
> I already skip certain Guava versions based on JDK.
> 
> Julian
> 
> 
> 
>> On Jun 12, 2018, at 12:42 PM, Kevin Risden <krisden@xxxxxxxxxx> wrote:
>> 
>> We might want to skip JDK11 with ES 2.x. 2.x is EOL from Elastic. I can
>> look into this if it helps.
>> 
>> Kevin Risden
>> 
>> On Tue, Jun 12, 2018, 10:54 Christian Beikov <christian.beikov@xxxxxxxxx>
>> wrote:
>> 
>>> Seems the latest Java 11 build will be stricter about the manifest
>>> format when reading. Also see other reports here:
>>> 
>>> * https://bugs.eclipse.org/bugs/show_bug.cgi?id=535774
>>> *
>>> https://issues.jenkins-ci.org/browse/JENKINS-51871?workflowName=JNJira+%2B+In-Review&stepId=1
>>> 
>>> Not sure if there is anything you can do. I'd assume other tests that
>>> use e.g. Netty would fail compilation as well.
>>> 
>>> Mit freundlichen Grüßen,
>>> ------------------------------------------------------------------------
>>> *Christian Beikov*
>>> Am 12.06.2018 um 14:11 schrieb Sergey Nuyanzin:
>>>> Hello everyone
>>>> 
>>>> Just I have an issue related to compilation of calcite-elasticsearch2 on
>>>> travis
>>>> As I see it relates only jdk11 while with others compiles ok
>>>> e.g. https://travis-ci.org/apache/calcite/builds/391198921
>>>> 
>>>> could anyone please share knowledge how to overcome this?
>>>> 
>>> 
>>> 
>