osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

[GitHub] brooklyn-server issue #994: bump karaf version to get consistent jetty


Github user aledsage commented on the issue:

    https://github.com/apache/brooklyn-server/pull/994
  
    I changed a few more things as well when looking at this:
    
    In `pom.xml`:
    ```
    <karaf.plugin.version>4.1.6</karaf.plugin.version>
    ```
    
    In `karaf/features/pom.xml`:
    ```
    <versionRange>[4.1.6,)</versionRange>
    ```
    
    https://github.com/apache/brooklyn-ui/blob/master/modularity-server/features/pom.xml#L179 to version range `[4.1.6,)`. Without this last change, it failed with:
    ```
    [ERROR] Failed to execute goal org.apache.karaf.tooling:karaf-maven-plugin:4.1.2:verify (verify-brooklyn-ui-modularity-feature) on project brooklyn-ui-modularity-features: Verification failures: Verification failures:
    [ERROR]         Unable to resolve framework features
    [ERROR]         Unable to resolve framework features
    [ERROR]         Unable to resolve framework features
    ```
    ---
    On my old laptop, when trying to build with `mvnf ./ -DscmBranch=mater -DbuildNumber=1.0.0-SNAPSHOT`, I also had a weird (unrelated?) error, which went away when I bumped the `swagger-maven-plugin` to 3.1.7 (from 3.1.4). However I didn't hit this error when I built it on my new laptop!
    ```
    [INFO] Brooklyn REST API .................................. FAILURE [  2.858 s]
    
    [ERROR] Failed to execute goal com.github.kongchen:swagger-maven-plugin:3.1.4:generate (default) on project brooklyn-rest-api: Execution default of goal com.github.kongchen:swagger-maven-plugin:3.1.4:generate failed: Plugin com.github.kongchen:swagger-maven-plugin:3.1.4 or one of its dependencies could not be resolved: Failed to collect dependencies at com.github.kongchen:swagger-maven-plugin:jar:3.1.4 -> org.apache.commons:commons-lang3:jar:[3.4,4.0): No versions available for org.apache.commons:commons-lang3:jar:[3.4,4.0) within specified range ->
    ```


---