OSDir

[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Beam modules are not recognized after dataflow SDK upgrade


Did you get this error when running a pipeline ? Can you try installing google-cloud-dataflow on a fresh virtual environment ?

Thanks,
Cham

On Thu, Apr 5, 2018 at 8:51 AM OrielResearch Eila Arich-Landkof <eila@xxxxxxxxxxxxxxxxx> wrote:
Hello,

It is probably a FAQ question:

After executing:
pip install --upgrade google-cloud-dataflow 

The following command fires unrecognized module error:
from apache_beam.options.pipeline_options import GoogleCloudOptions

Could you please advice what is the way to get rid of that message. I tried 
pip install --upgrade apache-beam 

and it didn't solve the issue.
any hint is highly appreciated 

Thanks,