osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Flink 1.6 Support


There has not been any decision to move to 1.6.x for the next release yet.

There has been related general discussion about upgrading runners recently [1]

Overall we need to consider the support for newer Flink versions that users find (the Flink version in distributions and what users typically have in their deployment stacks). These upgrades are not automatic/cheap/fast, so there is a balance to strike.

The good news is that with Beam 2.8.0 you should be able to make a build for 1.6.x with just a version number change [2]  (Other compile differences have been cleaned up.)



On Tue, Oct 30, 2018 at 10:50 AM Lukasz Cwik <lcwik@xxxxxxxxxx> wrote:

On Tue, Oct 30, 2018 at 10:30 AM Jins George <Jins.George@xxxxxxxxx> wrote:
Hi Community,

Noticed that the Beam 2.8 release comes with flink  1.5.x dependency.
Are there any plans to upgrade flink to  1.6.x  in next beam release. (
I am looking for the better k8s  support in Flink 1.6)

Thanks,

Jins George