Therefore, I propose one of the following:
- creating a module called "sdks/tests" and place "load-tests" and "nexmark" modules inside it. Place the common code in "sdks/tests/common" (or similar) and reuse it in every testing code that needs it.
sdks/java/tests? Assuming this will be Java utility code and Java test suites.
I would prefer a more descriptive name than `common` if you can come up with something. As much as I usually dislike `util` in this case I would go with that, only because it names the thing what it is, rather than how it relates to other things (relationships change all the time). Not a big deal or a blocker.
Sounds great to me. More eyes on the Nexmark-related bits will definitely be valuable, too.