[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Beam Dependency Check Report (2018-09-10)


High Priority Dependency Updates Of Beam Python SDK:

Dependency Name Current Version Latest Version Release Date Of the Current Used Version Release Date Of The Latest Release JIRA Issue
google-cloud-bigquery 0.25.0 1.5.0 2017-06-26 2017-06-26BEAM-5079
google-cloud-pubsub 0.26.0 0.37.2 2017-06-26 2017-06-26BEAM-5223

High Priority Dependency Updates Of Beam Java SDK:

Dependency Name Current Version Latest Version Release Date Of the Current Used Version Release Date Of The Latest Release JIRA Issue
org.assertj:assertj-core 2.5.0 3.11.1 2016-07-03 2018-08-28BEAM-5289
com.google.auto.service:auto-service 1.0-rc2 1.0-rc4 2014-10-25 2017-12-11BEAM-4874
biz.aQute:bndlib 1.43.0 2.0.0.20130123-133441 2011-04-01 2013-02-27BEAM-4884
com.gradle:build-scan-plugin 1.13.1 1.16 2018-04-10 2018-08-27BEAM-5224
org.apache.cassandra:cassandra-all 3.9 3.11.3 2016-09-26 2018-07-25BEAM-5083
commons-cli:commons-cli 1.2 1.4 2009-03-19 2017-03-09BEAM-4896
commons-codec:commons-codec 1.9 1.11 2013-12-21 2017-10-17BEAM-4898
org.apache.commons:commons-dbcp2 2.1.1 2.5.0 2015-08-03 2018-07-13BEAM-4900
com.typesafe:config 1.3.0 1.3.3 2015-05-08 2018-02-21BEAM-4902
de.flapdoodle.embed:de.flapdoodle.embed.mongo 1.50.1 2.1.1 2015-12-11 2018-06-21BEAM-4904
de.flapdoodle.embed:de.flapdoodle.embed.process 1.50.1 2.0.5 2015-12-10 2018-06-21BEAM-4905
org.elasticsearch:elasticsearch 5.6.3 6.4.0 2017-10-06 2018-08-18BEAM-5225
org.elasticsearch:elasticsearch-hadoop 5.0.0 6.4.0 2016-10-26 2018-08-18BEAM-5226
org.elasticsearch.client:elasticsearch-rest-client 5.6.3 6.4.0 2017-10-06 2018-08-18BEAM-5227
org.elasticsearch.test:framework 5.6.3 6.4.0 2017-10-06 2018-08-18BEAM-5228
net.ltgt.gradle:gradle-apt-plugin 0.13 0.18 2017-11-01 2018-07-23BEAM-4924
com.commercehub.gradle.plugin:gradle-avro-plugin 0.11.0 0.15.0 2018-01-30 2018-08-27BEAM-5229
com.google.code.gson:gson 2.7 2.8.5 2016-06-14 2018-05-22BEAM-4947
com.google.guava:guava 20.0 26.0-jre 2016-10-28 2018-08-01BEAM-5085
org.apache.hbase:hbase-common 1.2.6 2.1.0 2017-05-29 2018-07-10BEAM-4951
org.apache.hbase:hbase-hadoop-compat 1.2.6 2.1.0 2017-05-29 2018-07-10BEAM-4952
org.apache.hbase:hbase-hadoop2-compat 1.2.6 2.1.0 2017-05-29 2018-07-10BEAM-4953
org.apache.hbase:hbase-server 1.2.6 2.1.0 2017-05-29 2018-07-10BEAM-4954
org.apache.hbase:hbase-shaded-client 1.2.6 2.1.0 2017-05-29 2018-07-10BEAM-4955
org.apache.hbase:hbase-shaded-server 1.2.6 2.0.0-alpha2 2017-05-29 2017-08-16BEAM-4956
org.apache.hive:hive-cli 2.1.0 3.1.0.3.0.1.0-136 2016-06-16 2018-09-10BEAM-5344
org.apache.hive:hive-common 2.1.0 3.1.0.3.0.1.0-136 2016-06-16 2018-09-10BEAM-5345
org.apache.hive:hive-exec 2.1.0 3.1.0.3.0.1.0-136 2016-06-16 2018-09-10BEAM-5346
org.apache.hive.hcatalog:hive-hcatalog-core 2.1.0 3.1.0.3.0.1.0-136 2016-06-16 2018-09-10BEAM-5347
net.java.dev.javacc:javacc 4.0 7.0.3 2006-03-17 2017-11-06BEAM-4969
org.slf4j:jcl-over-slf4j 1.7.25 1.8.0-beta2 2017-03-16 2018-03-21BEAM-5234
net.java.dev.jna:jna 4.1.0 4.5.2 2014-03-06 2018-07-12BEAM-4973
com.esotericsoftware.kryo:kryo 2.21 2.24.0 2013-02-27 2014-05-04BEAM-4975
org.apache.kudu:kudu-client 1.4.0 1.7.1 2017-06-05 2018-05-30BEAM-5087
io.dropwizard.metrics:metrics-core 3.1.2 4.1.0-rc2 2015-04-26 2018-05-03BEAM-4977
org.mongodb:mongo-java-driver 3.2.2 3.8.1 2016-02-15 2018-08-20BEAM-5235
io.netty:netty-all 4.1.17.Final 5.0.0.Alpha2 2017-11-08 2015-03-03BEAM-4981
io.opencensus:opencensus-api 0.12.3 0.15.1 2018-04-13 2018-08-28BEAM-5290
io.opencensus:opencensus-contrib-grpc-metrics 0.12.3 0.15.1 2018-04-13 2018-08-28BEAM-5291
org.apache.qpid:proton-j 0.13.1 0.29.0 2016-07-02 2018-08-10BEAM-5153
com.carrotsearch.randomizedtesting:randomizedtesting-runner 2.5.2 2.7.0 2017-07-04 2018-09-10BEAM-5348
org.scala-lang:scala-library 2.11.8 2.13.0-M5 2016-03-04 2018-08-28BEAM-5292
org.slf4j:slf4j-api 1.7.25 1.8.0-beta2 2017-03-16 2018-03-21BEAM-5003
org.slf4j:slf4j-jdk14 1.7.25 1.8.0-beta2 2017-03-16 2018-03-21BEAM-5004
org.apache.solr:solr-core 5.5.4 7.4.0 2017-02-14 2018-06-22BEAM-5006
org.apache.solr:solr-solrj 5.5.4 7.4.0 2017-02-14 2018-06-22BEAM-5007
org.apache.solr:solr-test-framework 5.5.4 7.4.0 2017-02-14 2018-06-22BEAM-5008
com.diffplug.spotless:spotless-plugin-gradle 3.6.0 3.14.0 2017-09-29 2018-07-24BEAM-5010
org.springframework:spring-_expression_ 4.3.18.RELEASE 5.1.0.RC3 2018-07-30 2018-09-10BEAM-5349
com.clearspring.analytics:stream 2.9.5 2.9.6 2016-08-01 2018-01-10BEAM-5014
org.elasticsearch.client:transport 5.0.0 6.4.0 2016-10-26 2018-08-18BEAM-5237
org.elasticsearch.plugin:transport-netty4-client 5.6.3 6.4.0 2017-10-06 2018-08-18BEAM-5238

A dependency update is high priority if it satisfies one of following criteria:

  • It has major versions update available, e.g. org.assertj:assertj-core 2.5.0 -> 3.10.0;
  • It is over 3 minor versions behind the latest version, e.g. org.tukaani:xz 1.5 -> 1.8;
  • The current version is behind the later version for over 180 days, e.g. com.google.auto.service:auto-service 2014-10-24 -> 2017-12-11.

In Beam, we make a best-effort attempt at keeping all dependencies up-to-date. In the future, issues will be filed and tracked for these automatically, but in the meantime you can search for existing issues or open a new one.

For more information: Beam Dependency Guide