osdir.com


[Date Prev][Date Next][Thread Prev][Thread Next][Date Index][Thread Index]

Re: Antlib SVN and antunit Java versions


On Tue, 18 Dec 2018 at 10:44, Dominique Devienne <ddevienne@xxxxxxxxx>
wrote:

> On Tue, Dec 18, 2018 at 9:21 AM Jaikiran Pai <jaikiran@xxxxxxxxxx> wrote:
>
> > [...] 2 jobs[1][2] which are for Antlib SVN and Antunit libraries.
>
> Both these jobs are configure for JDK 5 [...]
> > However, the Maven central repo [...[ has been configured not to let
> > clients with
> > lower TLS versions (lesser than TLSv1.2) to communicate with it. [...]
>
> But this version of TLS is only supported in a Java release after Java 1.5.
> > [...]
>
> Should we now mandate Java 1.8 at least?
> >
>
> Sounds completely reasonable to me. Thanks for the clear message. +1. --DD
>

I'd say the choices are:

   -  use Java 6 or 7 with command line switch forcing TLSv1.2 or Java 8
   and crosscompile to Java 5
   -  change to Java 8 to follow Ant 1.10

Java 9+ can only crosscompile to Java 6+. It will be interesting to see if
JEP 332 [1] gets backported...

Gintas

[1] https://bugs.java.com/bugdatabase/view_bug.do?bug_id=8202625