[GitHub] activemq-artemis issue #2206: ARTEMIS-2003 - Add bridge metrics
Github user jbertram commented on the issue:
I have a couple of concerns here:
1. The "enqueue" and "dequeue" nomenclature doesn't fit with existing metrics already exposed on, e.g. the queue control. On the queue control there are metrics like `messageCount`, `messagesAdded`, and `messagesAcknowledged`. In my opinion `enqueueCount` and `dequeueCount` should be renamed to something like `messagesPendingAcknowledgement` and `messagesAcknowledged` respectively.
2. The "Metrics" map is not consistent with the other control objects where metrics are individually accessible from the control. I can certainly see the benefit of having the map so all the metrics could be retrieved with a single call (which might be done by a remote client) instead of lots of calls to get each metric individually. However, there's also a benefit to having the metrics available individually so I recommend adding that option for consistency at the very least. Perhaps a future PR could add a "Metrics" map to the other applicable controls so all the controls would be fully consistent.